Go v2 modules has a problem

It’s true – this is not easy to get right at all.